• Evidenziare le celle Excel che contengono formule

    excelformule.jpg

    Purtroppo, Excel non dispone di uno strumento che permette di applicare una formattazione particolare alle celle che contengono delle formule. Questo sarebbe molto comodo per distinguerle visivamente dalle celle che contengono dei dati, il che faciliterebbe molto l’analisi di un foglio di lavoro complesso, soprattutto se non predisposto da noi.

    Fortunatamente, c’è una soluzione per ovviare al problema. La soluzione è disponibile per tutte le versioni di Excel.

    Per prima cosa occorre selezionare il foglio di lavoro per intero, facendo click sul quadrato all’incrocio fra le intestazioni delle righe e delle colonne. Una volta selezionato il foglio, se si sta lavorando con Excel 2003 o precedenti, bisogna scegliere “Modifica > Vai”; Excel mostrerà la finestra “Vai a” dalla quale si deve premere il pulsante “Speciale”, verrà così mostrata la finestra “Vai a formato speciale”.

    Si tratta di una finestra utile, ma poco utilizzata, che vi permette di selezionare rapidamente delle celle particolari, come quelle che contengono una formattazione condizionale o criteri per la convalida dei dati. Per selezionare le celle che contengono formule, basta selezionare l’opzione “Formule” e premete Ok. Tutte le celle che contengono formule verranno selezionate.

    Fare la stessa cosa con Excel 2007 e 2010 è ancora più semplice: dopo aver selezionato tutto il foglio di lavoro, nella scheda Home della barra multifunzione, nel gruppo Seleziona e trova, basta aprire il menu del pulsante Trova e seleziona e scegliere la voce Formule.

    Ora che le celle che contengono formule sono selezionate, facendo attenzione a non deselezionarle, si può applicare loro una formattazione che le distingua dalle altre

    Tags:

    Se vuoi aggiornamenti su Evidenziare le celle Excel che contengono formule inserisci la tua e-mail nel box qui sotto:


    Ho letto e acconsento l'informativa sulla privacy

    Si No

    Acconsento al trattamento dei dati personali di cui al punto 3 dell'informativa sulla privacy

    Si No

    Commenti

    1. ALFONSO dice:

      Buona sera
      Parlo l’excel 2007 “Convalida dati”.
      10 celle.il codice del conto C401137038,N101190099,N201030000,N205220099,N911000004,N911000005
      Allora,A1 digito C,B1 digito 4,C1 digito 0,D1 digito 1,E1 digito 3,F1 digito 7,G1 digito 0,H1 digito 3,I1 digito 3,J1 digito 8
      ogni cella riga e colonna?.
      Io clicco convalida dati su C e mi restituiscono i numeri C401137038,anche N101190099,però io vorrei cliccare su N 205220099 non mi restituiscono?
      Cosa Debbo fare? dovrei creare una formula?oppure un codice VBA?
      Potreste aiutarmi?
      grazie
      c.s.
      Alfonso

    2. Alessandra Salvaggio dice:

      Mi perdoni, ma non capisco la domanda.

    3. Alfonso dice:

      i numeri del conto
      C401137038
      N101190099
      N201030000
      N205220099
      N911000004
      N911000005
      10 caratteri,cioè una lettera C + 8 caratteri numeri
      vedi in alto
      Vorrei avere la convalida dati,però ogni una cella carattere
      Per esempio,io vado su convalida dati “C” e espongono i numeri (9 caratteri=9 celle e non 1 solo insieme)come avevo scritto la data del 30 aprile alle ore 9,13
      Spero che mi sono spiegato bene
      grz
      c.s.
      Alfo

    4. Alfonso dice:

      Buona sera
      Ho provato,su Excel 2007,non sono riuscito!

      C401137038
      N101190099
      N201030000
      N201030003
      N205220099
      N901100004
      N901100005
      ecc….

      Definisci
      Nuovo Nome:Conto
      Riferito a:=Foglio1!$A$1:$J$9

      A15
      Convalida dati
      Consenti:Elenco
      Origine:=Lettere cioè (riferito a:riferito a: A1:A9 C,N,N,N,N,N,N,ecc….)

      B15
      =CERC.VERT(A15;CONTO;0;FALSO)

      C15
      =CERC.VERT(A15;CONTO;1;FALSO)

      D15
      =CERC.VERT(A15;CONTO;2;FALSO)

      E15
      =CERC.VERT(A15;CONTO;3;FALSO)

      F15
      =CERCA.VERT(A15;CONTO;4;FALSO)

      G15
      =CERCA.VERT(A15;CONTO;5;FALSO)

      H15
      =CERCA.VERT(A15;CONTO;6;FALSO)

      I15
      =CERCA,VERT(A15;CONTO;7;FALSO)

      J15
      =CERCA.VERT(A15;CONTO;8;FALSO)

      Vado su A15 convalida dati e clicco su C mi restituiscono C401137038 ok e
      anche su N —> N101190099 ok,invece gli altri numeri che NON mi restituiscono
      cosa debbo fare?
      dovrei creare una formula oppure dovrei eseguire un codice VBA?
      spero che mi sono spiegato bene.
      grazie dell’aiuto
      Alfonso

      N.B.
      Alessandra Salvaggio! Capisci? :-)

    5. Salve Alfonso

      la sua richiesta sarebbe da porre in un forum, non in un blog su un post che non è in topic :)

      Le consiglio di provare a fare la stessa domanda sul forum di HTML.it

      http://forum.html.it

      dove certamente ci sono altri utenti in grado di aiutarla.

      Grazie

    6. Alfonso dice:

      ok
      grazie
      Questo non lo sapevo
      c.s.
      Alfonso :-)

    Commenta

    Your email address will not be published. Required fields are marked *