• Una somma con più condizioni

    sommapiuse.jpg

    Chi usa Excel si sarà trovato qualche volta ad aver bisogno di sommare delle celle che rispondono a più di un criterio. Fino alla versione 2003 questo richiedeva delle operazioni lunghe e complesse e la procedura non era per nulla semplice.

    Ora, dalla versione 2007 in avanti, tutto è diventato più facile e veloce grazie alla funzione SOMMA.PIÙ.SE che permette di specificare fino a 127 criteri. Anche senza esagerare col numero dei criteri, SOMMA.PIÙ.SE è davvero una funzione utile. SOMMA.PIÙ.SE si trova fra le funzioni matematiche ed è di utilizzo abbastanza semplice.

    Richiede un numero diverso di argomenti a seconda del numero dei criteri che si vogliono specificare, in ogni caso, la struttura dei criteri è costante:

    SOMMA.PIÙ.SE(Int_somma, Intervallo_criteri1, Criteri1, Intervallo_criteri2, Criteri2, Intervallo_criteri3, Criteri3…)

    Int_somma è l’intervallo delle celle in cui eseguire la somma, poi, le varie coppie Intervallo_criteri, Criteri permettono di specificare l’intervallo che deve rispondere a uno specifico criterio e quindi il criterio per selezionare le celle da sommare. È possibile specificare tutte le coppie Intervallo_criteri, Criteri che servono.

    Immaginiamo di voler sommare le spese alimentari del mese di gennaio, nel prospetto della figura che vi abbiamo proposto all’inizio di questo post. Dopo aver estratto nella colonna C il mese di ciascuna operazione con la funzione MESE(), possiamo usare la funzione SOMMA.PIÙ.SE per selezionare le righe relative a gennaio e agli alimentari e quindi fare la somma. La funzione da usare sarà

    =SOMMA.PIÙ.SE(A2:A11;C2:C11;1;D2:D11;"alimentari")

    Chi volesse provare questa funzione con Office 2010, di cui non esiste ancora la versione italiana, deve usare il nome inglese della funzione che è =SUMIFS()

    Tags:

    Se vuoi aggiornamenti su Una somma con più condizioni inserisci la tua e-mail nel box qui sotto:


    Ho letto e acconsento l'informativa sulla privacy

    Si No

    Acconsento al trattamento dei dati personali di cui al punto 3 dell'informativa sulla privacy

    Si No

    Commenti

    1. paolo dice:

      grazie, ottima spiegazione, mi piace. Io con office 2007 per ottenere lo steso risultato ho penato, utilizzando la funzione matrice.somma.prodotto

    Commenta

    Your email address will not be published. Required fields are marked *