• La funzione CONTA.PIU’.SE in Microsoft Excel

    Dire che un dato valore ricorre n volte equivale a dire che n celle contengono lo stesso valore: è questo l’assunto di base per ottenere il medesimo risultato da due formule differenti con Microsoft Excel.

    Supponiamo di avere una sequenza di celle “A1:A7″ contenenti i seguenti valori: 4; 2; 2; 5; 6; 6; 6; volendo conoscere quante volte si ripetono alcuni numeri possiamo impostare la seguente formula posizionandoci nella cella B1:

    =CONTA.PIÙ.SE(A1:A7;"=6")

    questa restituirà quante volte si ripete il numero 6; modificando il 6 in 2 la formula risulterà:

    =CONTA.PIÙ.SE(A1:A7;"=2")

    e restituirà quante volte si ripete il numero 2.

    Lo stesso risultato si ottiene se impostiamo un’altra formula basata sul calcolo delle celle contenenti un determinato dato (che può essere anche non numerico):

    =CONTA.SE(A1:A7;6)

    che restituirà “3″ ovvero il numero di volte che viene ripetuto il numero 6.

    Volendo complicare un po’ le cose, possiamo anche aggiungere che la prima funzione è più complessa della seconda, perché è stata pensata per elaborare risultati basati su criteri multipli: ad esempio, si possono contare le celle contenenti un numero maggiore o uguale a 2 e minore di 6.

    La formula diventerà:
    =CONTA.PIÙ.SE(A1:A7;">=2";A1:A7;")

    e darà come risultato “4″ avendo incluso l’intero intervallo “A1:A7″ e avendo quindi preso i numeri 2, 2, 4, 5 della successione data.

    Tags:

    Se vuoi aggiornamenti su La funzione CONTA.PIU’.SE in Microsoft Excel inserisci la tua e-mail nel box qui sotto:


    Ho letto e acconsento l'informativa sulla privacy

    Si No

    Acconsento al trattamento dei dati personali di cui al punto 3 dell'informativa sulla privacy

    Si No

    Commenti

    1. Luigi Falco dice:

      ciao, una domanda… se volessi fare la seguente operazione:
      =CONTA.SE(A1:A7;1)E B1:B7;1997)
      come devo scivere correttamente la formula. in pratica voglio in una cella il conteggio di quei record che hanno valore 1 nella colonna A e allo stessotempo valore 1997 nella colona B. spero di essermi spiegato. grazie

    2. Agnese Bascià dice:

      Non so se ho ben capito il tuo problema, comunque prova a scrivere la formula in questo modo:
      =CONTA.PIÙ.SE(A1:A7;1;B1:B7;1997)
      Spero ti sia d’aiuto

      Ciao

    3. salvatorluca fucci dice:

      Vorrei usare la modelità convalida ed utilizzare una formula che metta a confronto due colonne.

      Ottenere quindi un allarme nel caso in cui la prima e la seconda colonna contengano CONTEMPORANEAMENTE lo stesso numero.

      Dovrò tradurre tutto questo in francese, ma questo è un’altro problema.

      Grazie mille

    4. salvatorluca fucci dice:

      Ho sbagliato…. intendevo che il confronto è su una stessa sequenza di numeri sulle celle A1 e B1
      e sulle celle A2 E B2

      Scusate ma non riesco a spiegarmi meglio.

    5. claudio dice:

      ho un foglio con delle classifiche(classifiche fantacalcio x ogni giornata).in un’altro foglio vorrei calcolare quante volte una data squadra è arrivata prima.come posso fare?quale funzione devo utilizzare.grazie.

    6. luca dice:

      esiste una funzione simile in excel 2003 ?

    7. Mordechai dice:

      Ciao
      è possibile inserire un criterio tra dei nomi?
      Ad esempio, voglio vedere quante persone che non corrsipondono a questo nome sono comprese e corrispondono alla lettera B
      :
      =CONTA.PIÙ.SE(‘Foglio1′!$A:$A;” – Diverso da Mario Rossi – “;’Foglio1′!$H:$H;”B”)

      Spero di essermi spiegato bene =)

      Grazie in anticipo

    8. Germano dice:

      Salve
      Come devo fare con Excel 2002 per avere un dato ( allarme ) quando la stessa frase o numero mi compare in sequenza nella colonna più di N° volte

      Grazie mille

    9. Alma dice:

      Utilissimo ! grazie!

    10. MATTEO dice:

      DI EXCEL NE CAPISCO POCO PERO’ AVREI BISOGNO DI SOMMARE LE CELLE DI EXCEL DI UNA COLONNA OGNI 5
      COME POSSO FARE SENZA DOVER SCRIVERLE TUTTE

      ES: P5+P10+P15+P20 ECC. errivare a500 troppo complicato

      GRAZIE
      MATTEO

    11. roberto dice:

      aiutatemi: nella funzione conta.piu.se se inserisco come criterio il riferimento di una cella la formula mi da zero:

      esempio: nella formula sottostante il criterio C4 dovrebbe leggere il valore di data in esso contenuta.
      Se sostituisco a C4 il valore in esso contenuta “

    12. roberto dice:

      09/01/2010 funziona.
      =CONTA.PIÙ.SE(‘Ist. FR’!$B:$B;”

    13. Mirco dice:

      Ma la funzione CONTA.SE funziona davvero!?
      4 = = = = = 2
      ? 2 = 5 = = 4
      4 ? ? 3 | ?
      | ? | 1 ? 4
      5 = 3 ? | |
      ? | 2 | |
      ? | | 1 ? 2
      4 = 5 = 5 = 2
      Provate a farle contare quanti = ci sono in questa matrice.
      Può darsi che sbagli nell’impostare i parametri ma me ne conta 14 anziché 12.
      Potete aiutarmi? Grazie.

    14. piganu44 dice:

      scusate la poca dimestichezza. ho un problema: in un intervallo (poniamo a1:a10, ho una lista non ordinata di numeri interi con ripetizioni.esempio:
      4 3 5 2 6 8 3 6 6 3
      esiste un modo per sapere quanti valori diversi sono presenti nella sequenza? (in questo caso 6)
      grazie, ed un saluto caro. piero

    15. Mirco dice:

      Non conosco il contesto del tuo problema ma la soluzione più semplice che mi viene in mente mi sembra possa essere la seguente:
      Vettore 4 3 5 2 6 8 3 6 6 3
      Ordinamneto 2 3 3 3 4 5 6 6 6 8
      Selezione 1 1 0 0 1 1 1 0 0 1 6
      Formula =SE(B2=A2;0;1) =SE(C2=B2;0;1) =SE(D2=C2;0;1) =SE(E2=D2;0;1) =SE(F2=E2;0;1) =SE(G2=F2;0;1) =SE(H2=G2;0;1) =SE(I2=H2;0;1) =SE(J2=I2;0;1) =SE(K2=J2;0;1) =SOMMA(B3:K3)
      Scusa il disordine ma se prendi ciascuna riga (Vettore, Ordin ….) e la porti su un foglio Excel il tutto ti si chiarirà.
      Spero di esserti stato di aiuto. Ciao.

    16. GIADA dice:

      NELLA COLONNA DA E3 A E31 CI SONO DELLE TAGLIE DALLA M ALLA XXL

      NELLA COLONNA E36 A E40 CI SONO ALTRETTANTE TAGLIE DALLA M ALLA XXL TUTTE RELATIVE AL SOLITO ARTICOLO MA DIVISE NELLA COLONNA E DAL NOME DELL’ARTICOLO RISPETTIVAMENTE IN E32-E33-E34-E35 CI SONO DELLE SCRITTE CHE NON POSSO TOGLIERE
      CHE FORMULA DEVO SCRIVERE PER FARE IN MODO CHE MI CONTO NEI DUE INTERVALLI SEPARATI E3-E31 E E36-E40 QUANTE M ( E POI L – XL – XXL) CI SONO ?

    17. Agnese Bascià dice:

      Per Salvatorluca:

      la funzione corretta sarebbe “SE()”, ma avrei bisogno di qualche dato in più

      Ciao

    18. Agnese Bascià dice:

      Per Claudio, la funzione per il tuo problema di fantacalcio è Conta() (o COUNT() in inglese)

      Ciao

    19. Agnese Bascià dice:

      Per Mirco:
      il segno uguale deve essere messo fra virgolette doppie:”=”
      Altrimenti Excel lo legge come introduttivo di formula.

      Ciao

      Agnese

    20. Eugenio dice:

      Salve, come posso sapere quante volte in una riga, colonna oppure matrice è contenuto più volte lo stesso valore? Esempio: avendo il vettore 2,6,3,3,3,5,4,7,8,3,3 vorrei che la funzione calcoli che il n° 3 è contenuto più volte nel vettore, con la differenza che non devo impostare io il numero da cercare ma che lo verifichi la funzione che il 3 è il numero più volte contenuto nel vettore, altro esempio: qual’è la parola che ricorre più spesso in libro? Spero di essere stato chiaro

    21. Daniele dice:

      Avendo una colonna contenente i seguenti valori (come esempio): 2.6.5.18.25.6.5.23.36, vorrei sapere quante volte si ripete la sequenza 6.5

    22. LT dice:

      Ciao Agnese,
      mi è stato molto d’aiuto questo tuo articolo, solo che mi chiedevo se fosse possibile contare celle di un foglio e far scrivere il valore in un altro foglio, dello stesso file xls. Potresti integrare questa mia risposta nel tuo articolo e mi risolveresti un problema, grazie!!
      buona serata da Bologna! ;)

      PS: puoi rispondermi anche in pvt nella mail, spero a breve termine perché ne ho davvero bisogno, grazie!!

      Luca

    23. Giovanni dice:

      Ciao a tutti,
      vorrei un aiuto:
      allora io vorrei avere il conteggio delle volte che una colonna ripete la parola “time”, ma solo se un’altra colonna è compilata…..in pratica vorrei : CONTA.SE____ ma a condizione che un’altra colonna corrispondente alla stessa riga sia compilata. Qualcuno mi può dare una mano?
      grazie in anticipo

    24. Massimo dice:

      Vorrei riprendere l’argomento per fare una domanda sulla funzione conta.se che nel mio caso è diversa da quelle precedenti.
      Ho un elenco di persone inserite in un foglio dove si inseriscono i dati anagrafici e l’associazione sportiva di appartenenza.
      A me servirebbe una formula, su un altro foglio che dall’elenco precedente mi riporti in ordine decrescente il nome dell’associazione e in numero di iscritti.
      Io ci ho provato in diversi modi ma il risultato è stato pessimo.
      Grazie a chi mi può dare una mano.

    25. Franco dice:

      Salve,
      devo calcolare se lo stesso valore compare in due celle di una riga, tipo vero/falso e poi calcolare il n° di “veri” della colonna risultati.
      In pratica quante volte il cliente (riga 1,2,ecc) è venuto in ufficio la prima volta (colonna 1) ed è rimasto insoddisfatto (colonna 2)?
      E così via per: poco s./mediamente s./soddisfatto/ottimamente s. (colonne 3/4/5/6)e ripetere per “saltuariamente” e per “abitualmente” – grazie per ogni consiglio, purché comprensibile ad u-tonto, come me :-(

    26. Mauro dice:

      Buongiorno.
      Ho creato una tabella, invece di una pivot, che raccoglie dati di un foglio di N record utilizzando per ogni casella della tabella una funzione conta.piu.se.
      Ciò mi permette di rielaborare il foglio dei dettagli semplicemente con un copia incolla dei nuovi dettagli che cambiano ogni giorno.
      Ho utilizzato questa modalità perchè risulta più gradevole e più immedita rispetto ad una pivot.
      Ora però ho il problema di voler estrarre i record che soddisfano uno qualsiasi dei campi della tabella.
      Ovviamente se avessi la pivot basterebbe cliccare nel campo della pivot e mi aprire un nuovo foglio con i dettagli richiesti.
      Ma qui credo che dovrò inventarmi del codice, a meno che non ci sia una soluzione che spero lei abbia.
      Cordiali saluti

    27. dibo dice:

      Avrei bisogno di una formula che mi calcoli quante differenti ditte di corrieri arrivano ad ogni ora.
      Esempio: alle ore 8:00 arrivano i corrieri BIANCO, ROSSO, VERDE, e ancora ROSSO, alle ore 9:00 arrivano i corrieri ROSSO, GIALLO, BIANCO, e ancora ROSSO e GIALLO, in questo esempio alle ore 8:00 sono arrivate 3 ditte BIANCO, ROSSO e VERDE e alle ore 9:00 sono arrivate 3 ditte ROSSO, GIALLO e BIANCO, il totale delle ditte di trasporto arrivate tra le 8:00 e le 9:00 è uguale a 6.

      8:00 BIANCO
      8:00 ROSSO
      8:00 VERDE
      8:00 ROSSO
      9:00 ROSSO
      9:00 GIALLO
      9:00 BIANCO
      9:00 ROSSO
      9:00 GIALLO

      Grazie

    Commenta

    Your email address will not be published. Required fields are marked *