• Riconoscere i valori pari o dispari

    Se vogliamo riconoscere i valori pari o dispari dei nostri dati in Excel dobbiamo usare una funzione logica. In tal caso la formula da utilizzare sarà:

    =SE(INT(A1/2)=A1/2;"Pari";"Dispari")

    Vediamo la sintassi e la sua applicazione. Nella colonna A abbiamo i valori che vogliamo analizzare; nella colonna B inseriamo la formula

    =SE(INT(A1/2)=A1/2;"Pari";"Dispari")

    e trasciniamola tenendo premuto il pulsante sinistro del mouse sul rettangolino in basso a destra della cella fino alla fine dei dati in esame.

    Il risultato sarà che Excel ci restituirà come valori le parole Pari o Dispari a seconda del tipo di numero rilevato nella colonna A.

    La sintassi di questa formula è semplicissima: il foglio di calcolo prende il valore della cella A1, lo divide per due (A1/2) e lo confronta con la sua parte intera (INT). Se il risultato della divisione non ha restituito dei valori decimali allora il numero sarà pari e nella cella della colonna B comparirà la voce Pari. Viceversa per i numeri dispari.

    Le funzioni logiche possono essere modificate a proprio piacimento, variando ad esempio alcuni parametri: nel nostro caso avremmo potuto voler escludere tutti i numeri dispari, e quindi nella funzione invece di Dispari avremmo potuto scrivere No, e invece di Pari Sì. La nostra formula sarebbe quindi stata

    =SE(INT(A1/2)=A1/2;"Sì";"No")

    Tags:

    Se vuoi aggiornamenti su Riconoscere i valori pari o dispari inserisci la tua e-mail nel box qui sotto:


    Ho letto e acconsento l'informativa sulla privacy

    Si No

    Acconsento al trattamento dei dati personali di cui al punto 3 dell'informativa sulla privacy

    Si No

    Commenti

    1. Senamion dice:

      Io utilizzo il resto, mi sembra più chiara:

      =SE(RESTO(A1;2);”Sì”;”No”)

    Commenta

    Your email address will not be published. Required fields are marked *