• La funzione SE in Excel

    Molto noto ai programmatori, il costrutto “If then Else”, una struttura condizionale utile nell’appurare il verificarsi di determinate condizioni e nell’attivare una conseguente azione, richiede tuttavia una minima conoscenza del linguaggio VBA.

    Excel, come altri applicativi Office, contiene molte funzioni in grado di semplificare la vita ai più pigri evitando di ricorrere a pratiche più complicate come la programmazione Visual basic.

    In questo caso la funzione utile a verificare una condizione ed eseguire una conseguente azione è la funzione SE.

    Supponiamo di aver bisogno di valutare il contenuto di una cella e, al verificarsi di una determinata condizione, assegnare un valore alla cella adiacente.

    Supponiamo, per fare un esempio, di aver bisogno di analizzare una colonna contenente i giorni della settimana; nella colonna adiacente vogliamo assegnare il valore “FESTIVO” quando nella cella affianco compare il valore “DOMENICA”.

    La sintassi della funzione SE è la seguente:

    =SE(test;Vero;Falso)

    Vediamo il nostro esempio:

    =SE(A1="Domenica";"Festivo";"Non Festivo")

    In questo modo possiamo assegnare ad una cella il compito di verificare il valore della cella A1; qualora il test risultasse “VERO” la cella assumerebbe il valore “Festivo”, in caso contrario assumerebbe il valore “Non festivo”.

    Come al solito il consiglio è sperimentare.

    Tags:

    Se vuoi aggiornamenti su La funzione SE in Excel inserisci la tua e-mail nel box qui sotto:


    Ho letto e acconsento l'informativa sulla privacy

    Si No

    Acconsento al trattamento dei dati personali di cui al punto 3 dell'informativa sulla privacy

    Si No

    Commenti

    1. merd dice:

      in questa guida manca il se NEL se .-.
      aggiungilo

    Commenta

    Your email address will not be published. Required fields are marked *