• Arrotondare alla ennesima cifra significativa con Excel o OO Calc

    calc-arrotonda-cifre-n-300.jpg

    In un precedente articolo si è analizzato come arrotondare un numero prodotto da calcoli Excel o OO Calc alla ennesima cifra dopo la virgola. La funzione “ARROTONDA” (o “ROUND” per la versione inglese) è perfetta per questo scopo e assieme a “ARROTONDA.PER.ECC” (“ROUNDUP”) e “ARROTONDA.PER.DIF” (“ROUNDDOWN”) costituisce uno strumento ideale per effettuare i calcoli con precisione ma rappresentare i dati come più opportuno e magari visivamente più appropriato per l’audience attuale.

    Un’estensione della funzionalità di arrotondamento di numeri non interi è quella della scelta del numero di cifre significative per un numero intero. Ad esempio avendo una contabilità precisa di un certo lavoro da milioni di euro, che si estende con precisione di 1 euro, è di certo corretto, ma far vedere solo l’ordine di grandezza del costo finale (diciamo alle migliaia di euro) può essere utile nella descrizione dei dati al management o a colleghi. Per far questo in maniera semplice potremo usare un’elegante soluzione che consente di passare alla funzione ARROTONDA (ROUND) un argomento specifico così da ottenere il numero di cifre significative volute.

    Per fare questo calcolo si dovrà così procedere. Assumendo che nella casella A1 ci sia la cifra intera di cui vogliamo far vedere le n cifre più significative, e che n, contenuto in A2, sia il numero di cifre significative volute, potremo usare la seguente formula:

    =ARROTONDA(A1;A2-1-INT(LOG10(ASS(A1))))

    o in inglese:

    =ROUND(A1;A2-1-INT(LOG10(ABS(A1))))

    Ad esempio, inserendo in A1 la cifra di progetto di 8.954.904 euro e volendo metterne in mostra solo le prime 2 cifre avremo un arrotondamento automatico a 9 milioni (con arrotondamento superiore viste le cifre seguenti). Mettendo in arrotondamento alla terza cifra significativa avremo invece: 8.950.000 (con arrotondamento inferiore viste le cifre seguenti).

    Una funzionalità utile per un display sempre appropriato di qualunque cifra all’ordine di grandezza desiderato.

    Tags:

    Se vuoi aggiornamenti su Arrotondare alla ennesima cifra significativa con Excel o OO Calc inserisci la tua e-mail nel box qui sotto:


    Ho letto e acconsento l'informativa sulla privacy

    Si No

    Acconsento al trattamento dei dati personali di cui al punto 3 dell'informativa sulla privacy

    Si No

    Commenta

    Your email address will not be published. Required fields are marked *